Results 1 to 5 of 5

Thread: Using BUNDLE in 1.4.0.1 under WINDOWS-98SE

  1. #1

    Using BUNDLE in 1.4.0.1 under WINDOWS-98SE

    Eros:

    I have BUNDLE 1.4.0.1 working fine under WINDOWS-XP, however, I can't seem to get it to do anything under WINDOWS-98SE.

    I have not tried earlier versions of BUNDLE on WINDOWS-98SE so I don't know if this problem is unique to 1.4.0.1 or not.

    Don B.
    XPS 1710

  2. #2
    thinBasic author ErosOlmi's Avatar
    Join Date
    Sep 2004
    Location
    Milan - Italy
    Age
    57
    Posts
    8,795
    Rep Power
    10

    Re: Using BUNDLE in 1.4.0.1 under WINDOWS-98SE

    Yes Don,

    you are right. Bundling operation seems not possible under Win9x system (Me included).
    Bundled scripts produced under XP seems working though also under Win9X.

    Making this tests, I've found another possible bug. There are some modules like (OS and Console) that are produced into 2 different version depending on the OS. When you install thinBasic under WinNT class machines (from Win2K above), the NT version of those modules are installed while if you install thinBasic under Win9x, than the Win9x of those modules are installed. This will create problems when a script containing one or more of those modules is bundled under NT class machines and executed under Win9x. Modules will not load due to missing API functions. We need to find a way to bundle different modules versions or use dynamic linking instead of static linking.

    I'm sorry, but we need some time to check the reasons. Quite sure it is an unsupported API calling.

    Thanks for reporting.
    Eros
    www.thinbasic.com | www.thinbasic.com/community/ | help.thinbasic.com
    Windows 10 Pro for Workstations 64bit - 32 GB - Intel(R) Xeon(R) W-10855M CPU @ 2.80GHz - NVIDIA Quadro RTX 3000

  3. #3

    Re: Using BUNDLE in 1.4.0.1 under WINDOWS-98SE

    One possible solution is add on the bundle creation panel the required OS where run the bundled executable, on bundle start up check the OS requirement and stop the execution if not satisfied.
    Please let me know what do you think. Thanks

    Regards,
    Roberto
    http://www.thinbasic.com

  4. #4
    thinBasic author ErosOlmi's Avatar
    Join Date
    Sep 2004
    Location
    Milan - Italy
    Age
    57
    Posts
    8,795
    Rep Power
    10

    Re: Using BUNDLE in 1.4.0.1 under WINDOWS-98SE

    Roberto,

    the problem regarding different modules version is secondary. Important for the moment is to have bundling working on Win9x OS.
    After that we can discuss privately about possible solutions for modules having different versions. I have already some ideas.

    Ciao
    Eros
    www.thinbasic.com | www.thinbasic.com/community/ | help.thinbasic.com
    Windows 10 Pro for Workstations 64bit - 32 GB - Intel(R) Xeon(R) W-10855M CPU @ 2.80GHz - NVIDIA Quadro RTX 3000

  5. #5

    Re: Using BUNDLE in 1.4.0.1 under WINDOWS-98SE

    Please find the attached ThinAIR's new version that solve the trouble found using Bundle under Windows 98/Me

    Regards,
    Roberto

    ATTENTION:
    to be used only on Win9x systems to test if bundling is ok or not.
    If problemis fixed, it will be present in next release.


    ADDED:
    attached file removed. Feature already present in current thinBasic preview release.
    http://www.thinbasic.com

Similar Threads

  1. Problem running thinForm (1.6) under 98SE
    By GSAC3 in forum thinBasic General
    Replies: 4
    Last Post: 27-05-2008, 20:55

Members who have read this thread: 0

There are no members to list at the moment.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •