Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: thinBasic 1.10.x

Share/Bookmark
  1. #11
    a far guess that the kcvinu problem is that his system needs to enable the support to east asian languages, in the case of windows xp it is in control panel like this: and it needs the windows xp CD, havn't tested it in win7 or more.
    Click image for larger version. 

Name:	cPanel.JPG 
Views:	27 
Size:	68.4 KB 
ID:	9723

    the Malayalam is displayed correctly on my english system with east language support using thinbasic scintilla editor, but the font size is very very small look the picture:
    Click image for larger version. 

Name:	unicode.PNG 
Views:	14 
Size:	1.6 KB 
ID:	9724

  2. #12
    Hi Petr,
    Thanks for your reply. I have typed those letters to editor. I am using an input method editor whih uses low level keyboard hook to convert English letters to Malayalam. More over, I have no problem in typing Malayalam in Scintilla editor of AutoIt and AutoHotkey.

  3. #13
    @primo,
    Thanks but that is not my problem. I can type Malayalam anywhere except thinbasic IDE.

  4. #14
    kcvinu, , there is an old but nice scintilla editor for thinbasic from Josť Roca, download it from here:
    http://www.thinbasic.com/community/s...ll=1#post84201
    just run thinSed.exe and by default it deals with c:\thinbasic
    in fact i can't paste unicode chars in it, but try it after inspecting Options-> colors and fonts. or tools ...
    there is also Edit-> Paste and Paste from internet explorer
    and other features.

  5. #15
    @primo,
    ThinSed is not displaying Malayalam correctly. Same as ThinAir. But miraculously, thinAir support Malayalam when we paste text in Malayalam. It displays correct Malayalam and compiled it. See the result in this attachment.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Captured_000143.jpg 
Views:	24 
Size:	87.4 KB 
ID:	9725  

  6. #16
    @Eros, Plsease set an option for user to set the encoding of the file to utf-8 or ASCII . I think it can be set like "code.page=65001".

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •