View Full Version : Demo

11-03-2009, 13:45

i want to know how many frames do you get ?
with a delay from 10 milisec, i get 65 frames.
when i have no delay, i get 168 frames.
press space bar for no delay !
i have added scrolling and scalesprite to my engine.

thinBasic makes an defective ".exe"
i cannot run this ".exe", because something is missing !
i took again the version

thank you.

11-03-2009, 15:23
58 FPS with delay
155 FPS without
but on an embedded Intel GPU and Pentium 4 HT (I'm at work).
I will test on my development PC when at home.

thinBasic makes an defective ".exe"
i cannot run this ".exe", because something is missing !
i took again the version

What Operating system?

Petr Schreiber
11-03-2009, 16:16
226 FPS in faster mode on GeForce 9500GT.

Can we expect some space game ;)?


Michael Clease
11-03-2009, 16:48
on my work computer I get 65 fps and 225 with the space bar.

11-03-2009, 17:53
Hi Eros,

operation system is windows XP professional
version 2002
service pack 1

at first a game, like PacMan or similar.

thank you to all.

11-03-2009, 22:40
Do not know if this can help but attached to this post a file with an old example of horizontal mapping from (if I remember well) Michael Hartlef and optimized by Petr

11-03-2009, 23:40
Hi Eros,

i will try this on my system and will see what passes here!
Thank you for your effort.

12-03-2009, 01:08
I get around 430fps on my Gtx280

12-03-2009, 13:47
MouseTrap, is this a terrestrial machine or an extraterrestrial one ?
430 fps without space bar or with space bar?

12-03-2009, 13:51
I suppose it is from the scrolling example I posted.

Peter I'm investigating about the problem you mentioned to execute bundled exe created with thinBasic
If you have the opportunity, can you send me the bundled exe not working at: support at thinbasic dot com
Possibly I would like to understand the reasons.


12-03-2009, 15:39
Hi Eros,

that's okay now!
I have thinBasic again installed newly. Version
It seems correct to function, i got an "EXE" with all files.
But a thinBasic directory was not designed. i meant that Folder
where all settings are stored.
I did it by hand, installed a folder in my "EIGENE DATEN" directory.
This folder stays always empty! But the settings was stored!
But i do not know where they are lying! Is it Microsoft magic ?